Страница 1 из 1

dovecot и дериктория для входящей почты

Добавлено: 2010-06-28 19:40:46
UserNet
Народ, есть очень тупой вопрос ни как не получается обойти проблему
есть свзяка postfix + dovecot,
вот конфиги
конфиг postfix

Код: Выделить всё

myhostname = domain.su
mydomain = domain.su
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
myorigin = $myhostname
local_transport = virtual
mydestination =  localhost.localdomain, localhost
mynetworks = 127.0.0.0/8, 192.168.1.0/24
inet_interfaces = all
smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
biff = no
recipient_delimiter = +
home_mailbox = Maildir/
mail_spool_directory = /var/mail
queue_directory = /var/spool/postfix
delay_warning_time = 4h
smtpd_tls_cert_file=/etc/ssl/certs/ssl-cert-snakeoil.pem
smtpd_tls_key_file=/etc/ssl/private/ssl-cert-snakeoil.key
smtpd_use_tls=yes
smtpd_tls_session_cache_database = btree:${queue_directory}/smtpd_scache
smtp_tls_session_cache_database = btree:${queue_directory}/smtp_scache
smtpd_sasl_auth_enable = yes
smtpd_sasl_authenticated_header = yes
smtpd_sasl_local_domain = $myhostname
smtpd_sasl_path = private/auth
smtpd_sasl_security_options = noanonymous
smtpd_sasl_type = dovecot
virtual_alias_maps = mysql:/usr/local/etc/postfix/mysql_virtual_alias_maps.cf
virtual_gid_maps = static:506
virtual_mailbox_base = /usr/mail
virtual_mailbox_domains = mysql:/usr/local/etc/postfix/mysql_virtual_domains_maps.cf
virtual_mailbox_maps = mysql:/usr/local/etc/postfix/mysql_virtual_mailbox_maps.cf
virtual_minimum_uid = 506
virtual_transport = virtual
virtual_uid_maps = static:506
broken_sasl_auth_clients = yes
smtpd_recipient_restrictions = permit_mynetworks,permit_sasl_authenticated,reject_non_fqdn_hostname,reject_non_fqdn_sender,reject_non_fqdn_recipient,reject_unauth_destination,reject_unauth_pipelining,reject_invalid_hostname
конфиг dovecot

Код: Выделить всё

base_dir = /var/run/dovecot/
protocols = pop3 pop3s imap imaps
log_timestamp = "%Y-%m-%d %H:%M:%S "
login_log_format_elements = user=<%u> method=%m rip=%r lip=%l %c
syslog_facility = mail
info_log_path = /var/log/dovecot.log 
ssl_cert_file = /etc/ssl/certs/ssl-cert-snakeoil.pem
ssl_key_file = /etc/ssl/certs/private/ssl-cert-snakeoil.key
login_user = dovecot
mail_location = maildir:/usr/mail/%u/Maildir:INDEX=/usr/mail/%u
mail_privileged_group = mail 
mail_full_filesystem_access = no
first_valid_uid = 100
auth default {
mechanisms = plain login
socket listen {
client {
path = /var/spool/postfix/private/auth
mode = 0660
user = postfix
group = postfix
}
}
passdb sql {
args = /usr/local/etc/dovecot-sql.conf
}
userdb sql {
args = /usr/local/etc/dovecot-sql.conf
}
}
Входящая почта почта попадает в каталог /usr/mail/user@domain.su/new, а потом я не могу получить это почту не через web-интерфейс, не через почтового клиента, где затесалась ошибка?

Re: dovecot и дериктория для входящей почты

Добавлено: 2010-06-28 20:41:36
Alex Keda
в выборе postfix, очевидно =)

Re: dovecot и дериктория для входящей почты

Добавлено: 2010-06-29 9:17:45
ivan__
UserNet писал(а): Входящая почта почта попадает в каталог /usr/mail/user@domain.su/new, а потом я не могу получить это почту не через web-интерфейс, не через почтового клиента, где затесалась ошибка?
А в логах-то что?
В master.cf добавил?

Код: Выделить всё

dovecot   unix  -       n       n       -       -       pipe flags=DRhu user=postfix:postfix argv=/usr/local/libexec/dovecot/deliver -f ${sender} -d ${recipient}

Re: dovecot и дериктория для входящей почты

Добавлено: 2010-06-29 9:24:47
aleshgo
Возможно проблема в правах доступа.

Re: dovecot и дериктория для входящей почты

Добавлено: 2010-06-29 12:30:42
moury
UserNet писал(а): mail_location = maildir:/usr/mail/%u/Maildir:INDEX=/usr/mail/%u

Входящая почта почта попадает в каталог /usr/mail/user@domain.su/new, а потом я не могу получить это почту не через web-интерфейс, не через почтового клиента, где затесалась ошибка?
Первая мысль после чтения Вашего конфига: постфикс кладет почту в /usr/mail/user@domain/new, а dovecot ищет ее в /usr/mail/user@domain/Maildir/new.

Re: dovecot и дериктория для входящей почты

Добавлено: 2010-06-29 21:04:55
FiL
moury писал(а):
UserNet писал(а): mail_location = maildir:/usr/mail/%u/Maildir:INDEX=/usr/mail/%u

Входящая почта почта попадает в каталог /usr/mail/user@domain.su/new, а потом я не могу получить это почту не через web-интерфейс, не через почтового клиента, где затесалась ошибка?
Первая мысль после чтения Вашего конфига: постфикс кладет почту в /usr/mail/user@domain/new, а dovecot ищет ее в /usr/mail/user@domain/Maildir/new.
учитывая, что в постфиксе все-таки стоит home_mailbox = Maildir/ то скорее всего там где-то глубже напортачено. Например в виртуальных юзерах/ящиках.

Re: dovecot и дериктория для входящей почты

Добавлено: 2010-06-30 9:35:26
moury
FiL писал(а): учитывая, что в постфиксе все-таки стоит home_mailbox = Maildir/ то скорее всего там где-то глубже напортачено. Например в виртуальных юзерах/ящиках.
А при чем тут home_maildir? UserNet явно блокирует использование этого параметра.

Причина проблем - попытка настроить почтовую систему по принципу бульдозера. Отсюда такие перлы, как использование без нужды "local_transport=virtual", и игнорирование домашней директории в dovecot, и принадлежащий MTA юзер как владелец почтовых ящиков. Конфигурация - очень опасная. И очень странная - в отличие от экзима, рекомендации по настройке связки postfix+dovecot на каждом углу лежат. Но... админ принял решение настраивать именно так, и требовать настройки почтовой системы с нуля, по-человечески, никто не вправе.

Поэтому лучше ограничиться констатацией того факта, что MTA настроен на доставку в одно место, а POP/MAP-сервер - на забор из другого.