Страница 1 из 1

Настройка Exim + Dovecot

Добавлено: 2010-06-27 9:24:22
Manul
Добрый день. Помогите пожалуйста разобраться.

На VPS сервере предустановлен exim + dovecot

Проблема вот какая: при старте exim выводится сообщение:

/etc/init.d/exim start
: command not found2:
: command not found6:
: command not found9:
: command not found12:
* Starting exim... [ !! ]
* ERROR: exim failed to start

Настройки стандартные, ничего не менял сначала, потом пробовал залить в конфиг также как написано в статье найдейной мной: http://sys.net.ru/docs/kak-stavit-eximdovecot/

результат тот же самый.

Что интересно: с dovekot почти тоже самое

если конфиг стандартный (но в нем как бы получается все строки отменены символом #)

выводится:

/etc/init.d/dovecot start
: command not found2:
: command not found6:
: command not found9:
: command not found12:
* Starting dovecot...
Info: If you have trouble with authentication failures,
enable auth_debug setting. See http://wiki.dovecot.org/WhyDoesItNotWork

(вроде запустился, но почему "command not found" ?)

Если вставлю туда настройки, то:

Error: Error in configuration file /etc/dovecot/dovecot.conf line 15: Unknown setting: default_mail_env
Fatal: Invalid configuration in /etc/dovecot/dovecot.conf
* Starting dovecot...
Error: Error in configuration file /etc/dovecot/dovecot.conf line 15: Unknown setting: default_mail_env
Fatal: Invalid configuration in /etc/dovecot/dovecot.conf

При этом default_mail_env обозначает папку под почту. У меня это: /var/mail (папка существует, проверял)

Почтовый клиент выдает ошибку: 10061, то есть не может присоединится к порту 110 сервера входящей почты POP3

Помогите пожалуйста разобраться, просто клиенты захотели переехать на VPS и выбрали без панели управления, а я если честно эти почтовые серверы первый раз в жизни вижу. Вот и мучаюсь уже вторую неделю с настройкой почты.

Буду благодарен за любой ответ!

Re: Настройка Exim + Dovecot

Добавлено: 2010-06-27 12:58:05
Вася
А ты не из chroot окружения их запускаеш. Какой дистриб используеш. А в логах пишет какие именно команды не найдены.

Re: Настройка Exim + Dovecot

Добавлено: 2010-06-27 14:16:34
Manul
Дистрибутив стандартный.
Основные программы предустановленные на сервере:
— Apache 2.2.10;
— PHP 5.2.8 (Zend Engine v2.2.0, Zend Optimizer v3.3.3);
— MySQL 5.0.70;
— Exim 4.69;
— Dovecot 1.1.7.

ОС: Gentoo Linux

Что значит chroot окружение?

Запускаю их по ssh протоколу от имени пользователя root

Re: Настройка Exim + Dovecot

Добавлено: 2010-06-27 15:49:18
Вася
Если хош могу уделенно посмотреть, пришли на мыло z.h.0.r.1.k@mail.bg логин и пароль от ssh.