Страница 1 из 1
Требуется помощь по Postfix/Exim, ваши рекомендации
Добавлено: 2008-09-18 10:59:03
Sanyh
Добрый день
начил разбираться с почтой с толкнулся с обилем возможностей, притом зачастую описывают одно и тоже разными путями

скажите мне нужна почта на Postfix в организации с 50 почтовыми ящиками
- без шифрования
- без сертификатов
- данные пользователей чтобы хранились в Mysql
-почту можно было забирать как с внутренней сети так и из интернета
1. почитал статьи вроде так понел что мой вариант это Postfix+Courier-Imap+Mysql, так или я ошибаюсь?
2. вот 3 статьи во всех есть отличия от какой лучше для новичка отталкиваться, т.к. есть различия в настройках
а:
http://www.sys-adm.org.ua/mail/mail-howto-p1.php
б:
http://www.lissyara.su/?id=1019
в:
http://www.crocodile.sumy.ua/articles/4
Re: Требуется помощь по Postfix, ваши рекомендации
Добавлено: 2008-09-18 11:16:29
Alex Keda
поставить экзим?
потом проще будет

Re: Требуется помощь по Postfix, ваши рекомендации
Добавлено: 2008-09-18 11:22:03
Sanyh
lissyara писал(а):поставить экзим?
потом проще будет

почему? интерфейс к нему есть?
Re: Требуется помощь по Postfix, ваши рекомендации
Добавлено: 2008-09-18 11:23:15
Alex Keda
Re: Требуется помощь по Postfix, ваши рекомендации
Добавлено: 2008-09-18 12:12:15
Sanyh
а против спама и вирусов что лучше прикрутить?
и какую с exim-ом использовать свзяки? imap ?
Re: Требуется помощь по Postfix, ваши рекомендации
Добавлено: 2008-09-18 12:40:33
Sanyh
Dovecot + exim к ним можно прикрутить RoundCube?
Re: Требуется помощь по Postfix, ваши рекомендации
Добавлено: 2008-09-18 13:58:35
Alex_hha
а против спама и вирусов что лучше прикрутить?
exim и сам хорошо со спамом борется, можно еще spamassassin.
pop/imap сервер любой, мта тут вообще не при чем. dovecot довольно таки неплохой выбор.
Re: Требуется помощь по Postfix, ваши рекомендации
Добавлено: 2008-09-18 14:40:49
Sanyh
начил настраивать Exim по статье
http://www.lissyara.su/?id=1175
написал конфиг, запустил exim но когда начинаю импортировать базу ошибка:
Код: Выделить всё
free# mysql --user=root --password=11111 < exim.sql
ERROR 1062 (23000) at line 2: Duplicate entry 'localhost-exim' for key 'PRIMARY'
free#
Re: Требуется помощь по Postfix, ваши рекомендации
Добавлено: 2008-09-18 14:50:03
Sanyh
Sanyh писал(а):начил настраивать Exim по статье
http://www.lissyara.su/?id=1175
написал конфиг, запустил exim но когда начинаю импортировать базу ошибка:
free# mysql --user=root --password=11111 < exim.sql
ERROR 1062 (23000) at line 2: Duplicate entry 'localhost-exim' for key 'PRIMARY'
free#
уже решил проблему
Re: Требуется помощь по Postfix, ваши рекомендации
Добавлено: 2008-09-18 15:45:10
Sanyh
дошел до настройки Courier Imap проблеммы а именно
/usr/home/lissyara/>echo 'courier_imap_imapd_enable="YES"' >> /etc/rc.conf
/usr/home/lissyara/>/usr/local/etc/rc.d/courier-imap-imapd.sh start
Starting courier_imap_imapd.
/usr/home/lissyara/>sockstat | grep couri
root couriertcp 630 3 tcp4 *:143 *:*
root courierlog 629 4 dgram -> /var/run/logpriv
root courierlog 613 4 dgram -> /var/run/logpriv
/usr/home/lissyara/>
/usr/home/lissyara/>echo 'courier_imap_pop3d_enable="YES"' >> /etc/rc.conf
/usr/home/lissyara/>/usr/local/etc/rc.d/courier-imap-pop3d.sh start
Starting courier_imap_pop3d.
/usr/home/lissyara/>sockstat | grep cour
root couriertcp 1533 3 tcp4 *:110 *:*
root courierlog 1532 4 dgram -> /var/run/logpriv
root couriertcp 630 3 tcp4 *:143 *:*
root courierlog 629 4 dgram -> /var/run/logpriv
root courierlog 613 4 dgram -> /var/run/logpriv
/usr/home/lissyara/>
так вот у меня courier-imap-imapd не стартует
не ошибок не показывает ничего:
и надпись не появлется Starting courier_imap_imapd.
Код: Выделить всё
free# /usr/local/etc/rc.d/courier-imap-imapd start
free# sockstat | grep couri
root couriertcp 939 3 tcp4 *:110 *:*
root courierlog 938 3 dgram -> /var/run/logpriv
root courierlog 899 3 dgram -> /var/run/logpriv
free# sockstat | grep cour
root couriertcp 939 3 tcp4 *:110 *:*
root courierlog 938 3 dgram -> /var/run/logpriv
root courierlog 899 3 dgram -> /var/run/logpriv
free#
Re: Требуется помощь по Postfix, ваши рекомендации
Добавлено: 2008-09-18 15:50:42
Sanyh
Sanyh писал(а):дошел до настройки Courier Imap проблеммы а именно
/usr/home/lissyara/>echo 'courier_imap_imapd_enable="YES"' >> /etc/rc.conf
/usr/home/lissyara/>/usr/local/etc/rc.d/courier-imap-imapd.sh start
Starting courier_imap_imapd.
/usr/home/lissyara/>sockstat | grep couri
root couriertcp 630 3 tcp4 *:143 *:*
root courierlog 629 4 dgram -> /var/run/logpriv
root courierlog 613 4 dgram -> /var/run/logpriv
/usr/home/lissyara/>
/usr/home/lissyara/>echo 'courier_imap_pop3d_enable="YES"' >> /etc/rc.conf
/usr/home/lissyara/>/usr/local/etc/rc.d/courier-imap-pop3d.sh start
Starting courier_imap_pop3d.
/usr/home/lissyara/>sockstat | grep cour
root couriertcp 1533 3 tcp4 *:110 *:*
root courierlog 1532 4 dgram -> /var/run/logpriv
root couriertcp 630 3 tcp4 *:143 *:*
root courierlog 629 4 dgram -> /var/run/logpriv
root courierlog 613 4 dgram -> /var/run/logpriv
/usr/home/lissyara/>
так вот у меня courier-imap-imapd не стартует
не ошибок не показывает ничего:
и надпись не появлется Starting courier_imap_imapd.
free# /usr/local/etc/rc.d/courier-imap-imapd start
free# sockstat | grep couri
root couriertcp 939 3 tcp4 *:110 *:*
root courierlog 938 3 dgram -> /var/run/logpriv
root courierlog 899 3 dgram -> /var/run/logpriv
free# sockstat | grep cour
root couriertcp 939 3 tcp4 *:110 *:*
root courierlog 938 3 dgram -> /var/run/logpriv
root courierlog 899 3 dgram -> /var/run/logpriv
free#
разобрался

Re: Требуется помощь по Postfix/Exim, ваши рекомендации
Добавлено: 2008-09-18 15:52:19
dikens3
Код: Выделить всё
#/usr/local/etc/rc.d/courier-imap-imapd.sh rcvar
$courier_imap_imapd_enable=YES
Re: Требуется помощь по Postfix/Exim, ваши рекомендации
Добавлено: 2008-09-18 16:38:39
Sanyh
Устоновил RoundCube полсденюю версию, почтовик exim + courier-imap
пытаюсь зайти в админку ввожу пароль иимя пользователя admin admin
сверху появляется надпись "Неудачное соединение с IMAP сервером"
и дальше ничего не происходит
в чем причина
ошибка
Код: Выделить всё
[18-Sep-2008 16:55:20 +0700] IMAP Error: Could not connect to free at port 143: Connection refused in on
[18-Sep-2008 17:26:10] PHP Warning: fsockopen() [<a href='function.fsockopen'>function.fsockopen</a>]: un
[18-Sep-2008 17:26:10 +0700] IMAP Error: Could not connect to free at port 143: Connection refused in on
[18-Sep-2008 17:42:26] PHP Warning: fsockopen() [<a href='function.fsockopen'>function.fsockopen</a>]: un
[18-Sep-2008 17:42:26 +0700] IMAP Error: Could not connect to free at port 143: Connection refused in on
[18-Sep-2008 17:42:29] PHP Warning: fsockopen() [<a href='function.fsockopen'>function.fsockopen</a>]: un
[18-Sep-2008 17:42:29 +0700] IMAP Error: Could not connect to free at port 143: Connection refused in on
хотя все работает вроде:
free# sockstat | grep couri
root couriertcp 969 3 tcp4 *:143 *:*
root courierlog 968 3 dgram -> /var/run/logpriv
root couriertcp 952 3 tcp4 *:110 *:*
root courierlog 951 3 dgram -> /var/run/logpriv
root courierlog 895 3 dgram -> /var/run/logpriv
free#
Re: Требуется помощь по Postfix/Exim, ваши рекомендации
Добавлено: 2008-09-18 16:41:16
dikens3
Sanyh писал(а):так вот у меня courier-imap-imapd не стартует
Re: Требуется помощь по Postfix/Exim, ваши рекомендации
Добавлено: 2008-09-18 16:50:04
Sanyh
на 143 порт цепляюсь нормально
Код: Выделить всё
free# sockstat | grep couri
root couriertcp 969 3 tcp4 *:143 *:*
root courierlog 968 3 dgram -> /var/run/logpriv
root couriertcp 952 3 tcp4 *:110 *:*
root courierlog 951 3 dgram -> /var/run/logpriv
root courierlog 895 3 dgram -> /var/run/logpriv
free# telnet localhost 143
Trying 127.0.0.1...
Connected to localhost.
Escape character is '^]'.
* OK [CAPABILITY IMAP4rev1 UIDPLUS CHILDREN NAMESPACE THREAD=ORDEREDSUBJECT THREAD=REFERENCES SORT QUOTA IDLE ACL ACL2=UNION STARTTLS] Courier-IMAP ready. Copyright 1998-2008 Double Precision, Inc. See COPYING for distribution information.
free#
Re: Требуется помощь по Postfix/Exim, ваши рекомендации
Добавлено: 2008-09-19 7:56:05
Sanyh
1.в логах ошибки , с чем связаны?
2. подскажите как сделать почтовый сервер внутри локальной сети, т.е. все на нем настроить а потом по быстрому сменить настройки на внешний интерфейс, возможно ли так и как сделать?
Код: Выделить всё
2008-09-19 08:52:24 1KgVAW-0000C5-SM <= root@free.southcoal.local U=root P=local S=842 from <root@free.southcoal.local> for root
2008-09-19 08:52:25 1KgVAW-0000C5-SM Error in system filter: failed to expand "${lookup mysql{SELECT 'address' FROM 'alias' WHERE 'address'='$recipients' AND 'copy_mail'='1' LIM
2008-09-19 08:52:27 exim 4.69 daemon started: pid=902, -q30m, listening for SMTP on port 25 (IPv6 and IPv4)
2008-09-19 08:52:27 1KgFwN-0000C3-O3 Error in system filter: failed to expand "${lookup mysql{SELECT 'address' FROM 'alias' WHERE 'address'='$recipients' AND 'copy_mail'='1' LIM
2008-09-19 08:52:27 1KgGwo-0000C5-QT Error in system filter: failed to expand "${lookup mysql{SELECT 'address' FROM 'alias' WHERE 'address'='$recipients' AND 'copy_mail'='1' LIM
2008-09-19 08:52:27 1KgPi8-0001vV-30 Error in system filter: failed to expand "${lookup mysql{SELECT 'address' FROM 'alias' WHERE 'address'='$recipients' AND 'copy_mail'='1' LIM
2008-09-19 08:52:27 1KgPi8-0001wZ-AA Error in system filter: failed to expand "${lookup mysql{SELECT 'address' FROM 'alias' WHERE 'address'='$recipients' AND 'copy_mail'='1' LIM
2008-09-19 08:52:27 1KgHBX-0001YJ-N5 Error in system filter: failed to expand "${lookup mysql{SELECT 'address' FROM 'alias' WHERE 'address'='$recipients' AND 'copy_mail'='1' LIM
2008-09-19 08:52:27 1KgVAW-0000C5-SM Error in system filter: failed to expand "${lookup mysql{SELECT 'address' FROM 'alias' WHERE 'address'='$recipients' AND 'copy_mail'='1' LIM
Re: Требуется помощь по Postfix/Exim, ваши рекомендации
Добавлено: 2008-09-19 22:59:50
Alex_hha
А почему в логах Could not connect to free, а не localhost?
Re: Требуется помощь по Postfix, ваши рекомендации
Добавлено: 2009-10-20 10:09:49
VaLoR
Sanyh писал(а):Sanyh писал(а):начил настраивать Exim по статье
http://www.lissyara.su/?id=1175
написал конфиг, запустил exim но когда начинаю импортировать базу ошибка:
free# mysql --user=root --password=11111 < exim.sql
ERROR 1062 (23000) at line 2: Duplicate entry 'localhost-exim' for key 'PRIMARY'
free#
уже решил проблему
подскажи зеленому SQL-щику - как решил? то же самое вылезло, только line 5 и key 1
спасибо заранее
Re: Требуется помощь по Postfix/Exim, ваши рекомендации
Добавлено: 2009-10-20 16:10:28
Laa
Открываете в редакторе файл с дампом базы, находите строчку, ключевое слово и тд... и думаете.
